Swiftってマクロ入ったらしいしこういうのマクロにしたほうがいいよなあと思いながら書いています
property wrapper でも行けそう…う〜んどうだろうなあ
property wrapper これがないからダメそうですね https://github.com/apple/swift-evolution/blob/main/proposals/0258-property-wrappers.md#referencing-the-enclosing-self-in-a-wrapper-type
Mastodon is the best way to keep up with what's happening.
Follow anyone across the fediverse and see it all in chronological order. No algorithms, ads, or clickbait in sight.